Pro feature & above
Fine-tune permissions with custom roles. To unlock, contact your customer success manager or the support team. Learn more
Problem
A user with the Can access POS permission tries to log in to a POS device but the system requires a manager PIN.
Cause
This occurs when a user tries to log in after a POS session ends for any of the following reasons:
- The Google Chrome window is closed.
- The POS device is turned off.
- Cache and cookies are cleared.
Once any of these happen, there is no way for the device to know which POS device was selected in the previous session. Since the staff member does not have access to the hardware settings, they cannot log in on their own and a manager PIN is required to select a POS device.
Solution
We recommend not turning off your POS device or closing the Google Chrome window during operating hours. This ensures the POS can remember the device that was used in the previous session.
In addition, we recommend not clearing your browser’s cache or cookies until after operating hours.
Alternatively, if you are experiencing this issue consistently, you can create a custom POS operator role in Venue Manager to allow staff members to select the POS device at login without a manager PIN.
Create a custom POS operator role
- From Venue Manager, go to Settings > Staff > Roles.
- Select Create role.
- Enter a Role title for the custom POS operator role.
- Select POS Operator from the Associated role dropdown.
- Select the checkbox Can adjust POS settings (device & hardware).
- Select Save.
Assign staff the custom POS operator role
- From Venue Manager, go to Settings > Staff > All staff. A list of all staff accounts appears.
- Select the options menu (3 dots) on the staff member you're assigning the role to.
- Select Edit.
- Select the custom POS operator role you created from the Role drop-down.
- Select Save.