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How do I change the phone number on guests' bank statements?

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Problem

Your personal phone number appears on guests’ bank statements.

Cause

The KYC information used for your ROLLER Payments account includes your mobile phone number and not your business phone number.

The phone number used for KYC verification is sent to banks after a transaction is completed. If you used your personal phone number during the verification process, ROLLER Payments will send that information to banks during the request.

Solution

Update your KYC information in ROLLER Payments through Venue Manager to use your business phone number.

This will restart your KYC process and delay payments for 4-5 business days on average. Plan on submitting your updated KYC information accordingly.

Follow the steps below to update the phone number associated with your KYC information.

Update your KYC information

  1. From Venue Manager, go to Settings > Integrations > ROLLER Payments.

  2. Select Launch verification.

  3. Select Go to identity verification.

  4. Select Business details.

  5. Update the Company phone number field to your business phone number.

  6. Select Signatory details.

  7. Update the Phone number field to your business phone number.

  8. Select Submit

Learn more

ROLLER billing & payment FAQs

ROLLER Payments: Know Your Customer (KYC)

ROLLER Payments performance dashboard

How do I verify ROLLER payments deposits?