ROLLER Payments
Not using ROLLER Payments? Contact your customer success manager or the support team to get started.
Problem
Your personal phone number appears on guests’ bank statements.
Cause
The KYC information used for your ROLLER Payments account includes your mobile phone number and not your business phone number.
The phone number used for KYC verification is sent to banks after a transaction is completed. If you used your personal phone number during the verification process, ROLLER Payments will send that information to banks during the request.
Solution
Update your KYC information in ROLLER Payments through Venue Manager to use your business phone number.
Follow the steps below to update the phone number associated with your KYC information.
Update your KYC information
- From Venue Manager, go to Settings > Integrations > ROLLER Payments.
- Select Launch verification.
- Select Go to identity verification.
- Select Business details.
- Update the Company phone number field to your business phone number.
- Select Signatory details.
- Update the Phone number field to your business phone number.
- Select Submit
Learn more
ROLLER Payments: Know Your Customer (KYC)
ROLLER Payments performance dashboard
How do I verify ROLLER payments deposits?